Forums  ›  RetroRoms  ›  Feedback

BDA Down?



I have reported to czokie, thanks for the info

ist back

It's down also right now ?

It was about 20 minutes ago when I tried.


It was about 20 minutes ago when I tried.

 with what result?

Down for me too.

Same here. It's down for me as well. 



It was about 20 minutes ago when I tried.

 with what result?

Still down when I tried.


still down...

Dead BDA... Yesterday and today... Very very dead. More dead than my matrimony.

yeah I know and reported it to czokie. Keep in mind that RR is not a professional service, give people time to fix it in their free time.




It was about 20 minutes ago when I tried.

 with what result?

Still down when I tried.


Ah OK. I imagined it but asked for further confirmation :)

Its fixed. To summarise the issue: The NAS (which hosts the files) has a default route, that goes to a gateway. That gateway is on a router, which CAN route the traffic to the server. And most of the time, it does... but sometimes, things dont work as expected. I've never been able to work out why...

But, I solved this by adding a static route on the NAS for the subnet used by the website, which should allow it to work bypassing the router - and sending the traffic direct to the node where the server is hosted. That works. EXCEPT, for some unknown reason - every so often - the server clears its route table. No idea why.

So. I solved that (today) with a scheduled task that runs every 15 minutes to check the route table on the NAS, and fix it if it is broken. When you cant hammer a nail into a hard piece of timber, get a bigger hammer!


Thanks for fixing this.  Can you double check the files uploaded on Nov-22? In particular, the gnw files in the MAME update.  gnw_mmousep seems to be incomplete (missing the SVG file) and gnw_dkcirc seems to be missing the new melody file.  Not sure if any others were effected. 

thats my part ;-)

^Thank you.

thanks for fix site.

Thank you smile

looks to be down for me now 12/11/2019

It's down now.

down again.frown

It's working now.


Some people were having issues related to membership levels. I was doing some database repair, and forgot to turn the BDA back on after the work. Still a few users with issues, but I'll give it another try in the near future to sort that out.


Hi... today I was running into problems... is this the same issue?  Thanks.

It looks like the webpage at might be having issues, or it may have moved permanently to a new web address.



The SSL certificate must be renewed.


Go here, it bypasses the error

Is there a way to access via FTP so that they do not need to be acquired one by one?

I'm trying to build my initial most current-most reliable set of MAME Roms. I realize it is more than possibly not the best use of this site's resources for me to do that, but if there is a torrent link or other link that can help, it would be most appreciated!

oops I am now seeing that this has been asked many times. Sorry for the trouble folks. I will figure it out.  Has something to do with jdownloader I see.


Looks like It's an HTTPS certificate expired issue.

I figured it out via Again sorry for the trouble.

The error still shows up with individual files.


Closing the browser and reconnecting fixes for a little while.

Dead BDA... ??¿

dba_down.PNG14.3K5 views

now I'm getting expired certificate (expired on 29/12/2010)

It works fine here.

The certificate expires on Saturday, 12 March 2022.


ok, it was an expired certificate .....czokie fixed it and improved the "*monitor" script ;-)

Thanks! it's working fine now!


PS: I meant expired on 29/12/2021, I don't know why I wrote 2010 LOL

I had updated my Firefox from a very old (severely tweaked) to the newest version 98.0.2 (forced in the beackground by installing Comodo Internet Security  - yuck!) on Win10 and now I can not download from Retroroms anymore.

The download page frame shows that the connection had failed at "".

I already tried to disable Ghostery and bypassed other filters without success. It is definitely a Firefox issue, because the Google Chrome browser works properly.

It's possibly your tweaked Firefox issue. I'm running the same version and can connect to the BDA.

You can open Firefox in Safe Mode by holding down the shift-key while opening Firefox, it will temporarily disable all addons.


I have now started Firefox in safe mode (disables all addons) and the problem is still there. May it be that the Comodo firewall intercepts the URL?

It was indeed the Comodo firewall. It did not change anything to whitelist the RetroRoms URL in the Web Filter section or disable it, Instead I had to add port 82 to the port group "HTTP" of the Firewall section to make it work.

I own a hardware firewall, great for my own "BDA", just setup port forwarding and an apache server on the other side and you are ready to go.

Forums  ›  RetroRoms  ›  Feedback